bcow - Lets Encrypt SSL API Errors – Incident details

All systems operational

Lets Encrypt SSL API Errors

Resolved
Operational
Started 2 months agoLasted about 4 hours
Updates
  • Resolved
    UTC
    Resolved

    We no longer see delays stemming from Lets Encrypt and the issue is considered resolved.

  • Identified
    UTC
    Identified

    We have identified an issue on free cert issuance and renewals for custom CDN domains. We have observed a delay from Lets Encrypt API endpoint causing these delays. Existing certificates on custom domains will continue to function as normal - however new and cert renewals via our free certificate option may experience a delay to the certificate issuance.