bcow - Degraded Performance in Singapore – Incident details
All systems operational
Degraded Performance in Singapore
Resolved
Degraded performance
Started 3 months agoMay 14, 2026Lasted about 1 hourMay 14, 20262:233:41 PMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has now been cleared.
Monitoring
UTC
Monitoring
UTC
We identified an outage in relation to an upstream network provider that resulted in partial degradation in Singapore, this is now resolved. We are currently monitoring the situation.
Update
UTC
Update
UTC
We are continuing to investigate this issue.
Update
UTC
Update
UTC
We are continuing to investigate this issue.
Investigating
UTC
Investigating
UTC
We are currently experiencing a network issue in our Singapore region, and as a result there may be degraded performance on CDN, Storage, Magic Containers and Database from the region. Our Engineering team are investigating the problem.